
What’s New in BullCharts
www.bullcharts.com.au

Version 4.3
Welcome to the latest revisions to Australia's BullCharts charting software.  
This version (4.3) runs on: Windows 7, Windows 8 (both 32-bit and 64-bit) and the 
new Windows 10. This version is not supported on Windows XP.

The last update to version 4.2 included some significant changes to the underlying 
database system, and the process for downloading data. With price data from 
additional exchanges available, the computer disk storage space requirement can 
be significantly greater than before. The reader is encouraged to also view the 
“What’s New in BullCharts Version 4.2” document for further details, especially if 
currently using BullCharts version 4.1 or earlier.

This upgrade to version 4.3 includes the following key features (plus others):

 Enhancing the recent changes to enable price data from more exchanges.

 Special support for interfacing MetaStock data, including for the additional 
exchanges.

 The ability to have multiple price charts, with several all synchronised to be 
the same security, and to have an “orphan” chart displaying data for a 
different security (ie. an unsynchronised chart).

 Updates to the BullCharts Help, with a new online KnowledgeBase.

 Many other smaller feature changes (see the Table of Contents on the next 
page for a list of these).

This document provides an overview of all the changes in this new Version 4.3.  
See a summary list in the Table of Contents on the next page.  Also refer to past 
“What's New” documents for a list of other revisions and changes in past version 
updates.

BullCharts staff

BullCharts support:
email: info@bullsystems.com.au 
phone: 02 9495 8400
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1. Data exchanges, databases and price data

New databases and “other exchange” data
Until BullCharts version 4.2, the Microsoft SQL database system was used to store all 
BullCharts data, and only comprised security data for all Australian securities (back to 
1985 — the start of the ASX as a single national exchange). With the recent upgrade of 
BullCharts to version 4.2, this was changed and expanded and the database system now 
in use is SQLite1. 

This change to the database system has made it easier to accommodate data from other 
exchanges, including commodities data and securities from other countries including New 
Zealand and USA (and others). (Also see more details in the “What’s New in v4.2” 
document.)

The location of the databases on your computer can be viewed, and changed. Use the 
menu option: Tools > Preferences > Files (tab), as shown in the screen shot below.

During the installation or upgrade to BullCharts v4.3, you have the opportunity to install 
some or all of the additional databases. If you find later that you no longer want to use a 
particular database, then you can simply use Windows Explorer to navigate to the relevant 
folder, and then simply delete the database.

1 — See SQLite details: https://en.wikipedia.org/wiki/SQLite 
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The BullCharts DataDownloader
The BullCharts DataDownloader (BCDD) tool is now used to manage the download of 
data, instead of the previously used download process. This tool can manage the 
download for data from different exchanges and has been used since the previous 
BullCharts upgrade to version 4.2. Some of the changes in this BullCharts version 4.3 are 
simply tweaks or enhancements to this process. (Also see more details in the “What’s New
in v4.2” document.)

Within this “What’s New” document there are references to using the BullCharts 
DataDownloader tool. Once BullCharts is running, you can access this down-loader tool by
any of the following methods:

● Menu option: Tools > Get Daily Data. This will open the BullCharts 
DataDownloader tool.

● Use <Ctrl>+G — The keyboard shortcut key combination using the Control key and
the letter “G” will trigger the “get data” operation. (This is indicated on the menu 
option: Tools > Get Daily Data.)

● Look for the BullCharts icon in the Windows System Tray
notification area (usually the bottom right corner of the
Windows screen), then right-click, then select “Settings...”
(see screen shot at right).

Auto download of snapshot data
For users with either the live data plan, or the intraday snapshot plan, the BullCharts 
DataDownloader tool might be set to “Auto Download” snapshot data every 10 minutes. 
The user might want to check this setting and adjust as required (remove the tick for Auto 
Download).
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Warning if download existing data
If the BullCharts DataDownloader is about to download data, but the database is already 
up to date, then the warning message shown below will be displayed. This can happen if 
you want to download data for a specific date (or date range) which might have been 
missed previously. 

There might be several days of data missing, perhaps due to a vacation, and which were 
not downloaded at the time. Or there might simply be some missing days in the original 
data stream from the data provider. Or the original data stream might have contained 
some incorrect or corrupt data, in which case downloading it again might fix the issue.

This message is simply an informational warning message.

Windows notification on data update
By default, when BullCharts had applied a data update in the past, it would display a 
notification message to advise that the operation had completed. This notification message
has been removed. For a user who uses the live data or snapshots during the day, the 
message could have been rather annoying because of its frequency.

Occasional incorrect message on data updates
On occasions, when doing a data update in earlier versions, BullCharts might have 
displayed a message incorrectly advising that the data plan does not support Snapshots. 
This feature now behaves correctly (a bug fix).
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2. MetaStock related features
A major change in this new version of BullCharts is the support for Metastock data, 
including the download and export of Metastock-format data.

Download and export in MetaStock format
Regarding MetaStock for OmniTrader and other programs that read the MS data format, 
there is now an option in BullCharts to export data from the BullCharts system into external
MetaStock format files. If the data is already in one of the BullCharts databases that you 
have installed, then it is extracted (exported) from there. If not, the data is downloaded 
over the internet (from the BullCharts / WebLink servers), and then exported.

This option is in the BullCharts DataDownloader window, and the MetaStock tab (see 
screen shot below). This screen also shows the various data sets that are available.

With reference to this screen shot, to
download and export MetaStock data
simply:

● Select the required data sets;
and

● Click on the “Collect Now”
button.

By default, the data is downloaded to
the local folder: C:\WebLinkData (see
the next screen shot below right).
The folder location can be changed
— see notes below.

Note the following key points:

1. You can download MetaStock
data for any of the available
exchanges. You don’t have to
have the same
exchange database
installed in BullCharts.

2. If the data set you
select is not available
on your computer, the
DownLoader will
download it into a
temporary file, and then
expand the data into
the desired folder
location as MetaStock
data.

3. Once selected, the
MetaStock data is
automatically converted
each day or you can
manually download it. 
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4. For users on the BullCharts live data plan, the ASX MetaStock data is updated 
every 10 minutes.

5. To change the target folder for the extracted MetaStock data, select from the 
BullCharts menu: Tools > Preferences > Files (tab), and scroll down to the 
Metastock Data option (see screen shot below). Note the options here include: 
“Change”, or “View Location”.

Backup the Metastock directory
The existing BullCharts Backup facility under the Tools menu item now has an option to 
also backup the Metastock directory. From the menu, select: Tools > Backup and scroll 
down the list. Note that backing up most BullCharts files is fairly quick, but the larger 
databases might take a few minutes (depending on the speed of the computer).
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Change location of Metastock files
There is an option to change the location of the Metastock files and move them to a new 
location. 

Display (M) for Metastock charts
When a chart is displayed using Metastock data, display “(M)” next to the symbol in the top
left corner of the chart to indicate it is using Metastock data from BullCharts.
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3. Sync and Unsync chart windows

Sync only some chart windows (ie. the UnSync feature)
This new feature enhancement is also referred to as the ability to “unsync selected 
windows”.

In BullCharts you have always been able to display more than one price chart at the same 
time — perhaps three charts for example (one daily, one weekly, one monthly) and 
arranged around the screen so all are visible (use the option to Tile Windows — either the
menu option or the toolbar button). These charts could be three different
securities of the same time period (eg. all daily charts), or they could be
“Synchronised” to all display the same security (using the toolbar button
“Synchronise all chart windows”, normally located on the Workspace toolbar on
the left side of the window — see screen shot at right). A collection of price
charts like this is a BullCharts Workspace. In addition, the workspace might
include additional window panes such as the Security Summary, News, market
announcements, market depth, etc.

However, analysis is sometimes needed in conjunction with other price charts,
such as the monitoring of an index (eg. the XJO). This would require some of the price 
charts to NOT be synchronised. It is now possible to synchronise all chart windows, and 
then “unsync” individual price chart windows by clicking the blue icon in the top right hand 
corner of a chart (see screen shot
at right). 

Your settings are remembered
when you want to resync the
windows again.

One possible example of a multi-
chart workspace is shown below,
and includes a monthly chart of
CBA (top left) and daily chart of
CBA (centre) with market depth
(right hand side) and the Security Summary (lower left).

Page 9 of 18 Printed: 19 Sep 2016 



What's New in BullCharts version 4.3

With your desired selection of single-security charts or windows set up, make sure to 
enable the “Synchronise all chart windows” option (the toolbar on the left of the window). 
Then you can add another chart for this security, and then “unsync” this chart from the 
sync group.

Special notes for Synch and UnSync
Special notes for use of this feature:

1. When this feature is in use, you might have one set of price chart windows (maybe 
just one, or more) displaying information for one security, and another set of 
windows (again, maybe just one, or more) for a different security. 

2. One set of windows will be the synchronised group of windows (referred to as the 
“sync” group). The other window(s) will be the “orphan” window(s).

3. There can only be one “sync” group of windows.

4. A window in the “sync” group can be removed from the group by clicking on the 
blue button in the top corner of its window. When you do this, the button changes 
colour from blue to white.

5. Another window can be added to the “sync” group by clicking on the otherwise blue
button (when unsynced, the button is white).

6. Non-chart windows can be included within the “sync” group of windows, but they 
cannot be removed the group, nor added to the group, as they don’t have the blue 
button. By unsyncing these windows, BullCharts would not know which security to 
relate it to.

Now, to change the security for one set of these displayed windows, note the following. 
The change of security (or change of symbol — same thing), will apply to the set of 
windows that is “in focus”. Changing the security for one window within a sync group will of
course change it for all windows within that synchronised group. If the window in focus is 
an “orphan” window (ie. no other windows are synchronised with it), then the change of 
security will only apply to that one window.

(This new feature was implemented in version 4.3.1)

Re-sync all chart windows
This is related to the “Synch only some windows” feature mentioned above. This option 
can be used when you wish to quickly resynchronise all chart windows, so as to have just 
one sync group, and no orphan windows.

The existing toolbar button “Synchronise all
chart windows” now has an optional feature
added to it to “Set All Charts To Sync” (see
screen shot at right).

(This new feature was implemented in
version 4.3.1.1)
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4. Updates to BullCharts Help

Accessing BullCharts Knowledge Base
This is a new Help option to compliment the BullCharts
Help User Manual. The BullCharts Knowledge Base is a
cloud based service that allows quick updates on-the-fly
to any support issues. 

The new web-based BullCharts KnowledgeBase can be
accessed from the menu option under Help (see the
screen shot at right). It can also be accessed directly at:
kb.bullcharts.com.au 

(Version 4.3.1.2)

Link to Accounts
Under some circumstances you might need to update
your email address or BullCharts system password (or
credit card details). There is now a link to access this
from the Help menu (see the screen shot below).

(Version 4.3.1.2)

Other help options
Note the other (existing) help menu options in the screen shots above.
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5. Other updates

Scheduled time to get data
The option to schedule the time to “Get Daily Data” has been changed to be “auto 
updated” for the ASX and overseas databases.

Alert Manager auto triggered
Once a data download has been
completed, the Alert Manager will be
triggered automatically. 

Also note the Alert Properties settings
under the menu option: 
Alerts > Properties 
(see screen shot at right).

Increase size of symbol box 
In the past, the security symbols (in the ASX data) were limited to only a few characters. 
But with the implementation of data from other exchanges, there are now securities (and 
perhaps commodities, etc.) with symbols of many characters. Therefore, the size of the 
symbol box (usually in the top left corner of the window)
has been increased to accommodate more characters.

This is the “Security” toolbar which can be displayed or
hidden using the menu option: View > Toolbars. 
Don’t forget that all toolbars can be dragged to another
location around the BullCharts window, and docked into a
new location.

Better video support for 4K Monitors
Some of the modern ultra-high resolution video monitors are compressing text or 
overlapping displayed screen elements within the BullCharts window. A number of the 
BullCharts dialogue boxes have been modified to “auto resize” to address this issue. 
Even so, there might still be an issue in
some situations (eg. in the BullCharts
Control Panel).
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New BullScript function — extend_to_right
A new BullScript function has been added to “extend a plot to the right”. It is demonstrated 
with the following example, and with reference to the daily price chart of the All Ordinaries 
(XAO) index below (note the thick black line is the XAO index):

[extend_to_right=14; target=price]
hist(Close,14);

On this chart, the standard function  hist(Close,14) is the thinner blue line running 
across the chart, but only up until the date of the vertical dashed red line (the latest date —
14th September). The rest of the blue line to the right of that date (and which is falling 
across the chart) is a result of the function:  extend_to_right=14

Don’t forget the  hist(Close,14)  function basically takes the plot of the Close price, 
and offsets it by 14 bars (in this case) to the right; but would normally not plot anything on 
the chart beyond the date of the latest data.

We can see in this example that when the  extend_to_right  function is used in 
conjunction with a function such as  hist, it extends the plot of the  hist  function to the 
right. This makes the plot of  hist  complete for all of the available price data. 

Note in this example that the parameter in the hist function is 14 bars, and the parameter 
in the extend_to_right function is set to the same value.
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Detailed WatchList — new items
The Detailed WatchList feature was added into BullCharts in Version 4.0 (see screen shot 
below), and it now has two more fields added:

● VWAP, and 

● Market Cap.

To view the Detailed WatchList, either double-click on
a watchlist (in the upper panel of the Security
Manager), or select the watchlist (by clicking on it once
to view the contents), and then use the button on the
Control Panel window (see screen shot at right).

To add or remove columns to the Detailed WatchList window, make sure it is the active 
window (click in it once), then use the menu option: Format > Current View... 
then select the data items to be added to, or removed from, the Detailed WatchList view.

Ribbon pane height
A number of chart indicators can be applied to the price chart as a “ribbon” across the 
bottom of the chart. A recent update enable the height of the ribbon to be increased. 

It is now possible to set the
ribbon height to zero to hide the
ribbon.

(Another way to hide a ribbon
indicator is to use the Layer
Manager, and untick its check
box).
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View a Chart Memo (Ctrl+M)
The Chart Memo is an existing feature in BullCharts. When viewed it is the bottom portion 
of the chart window, and can contain any textual information relating to that security (see 
screen shot below). You can view the memo text, or hide the memo text, and the memo 
text is associated with that particular security (regardless of which watchlists the security 
might be in).

To view the Chart Memo note for a security, use the menu option: 
View > Show Chart Memo, or use the keyboard shortcut Ctrl+M.

Note that the keyboard shortcut has been changed from Ctrl+W to Ctrl+M as it conflicted 
with the use of Ctrl+W to create a watchlist in some circumstances (eg. when viewing the 
results of a scan).

The following screen shot shows the Chart Memo pane across the bottom of the chart, 
containing a couple of words.
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BullCharts Quick Search 
The BullCharts search facility has been
enhanced. Use the “Quick Search” facility
within the BullCharts Control Panel
(remembering that the Control Panel
includes six tabs across the bottom for: 
Security Manager, Scan Manager, Search,
Layer Manager, Workspace Manager, and
Alerts — see the screen shot at right).

In the example search at right, the text “gold”
was searched for, and some of the resulting
securities which contain this text string in the
name are shown.

Search for comments
In BullCharts it is possible to include some
comment text with a watchlist entry, or to a
“chart memo” note. It is now possible to
search these comments for a particular text string.

In the example at right,
the search was for a text
string within the
“Comment” field.

In the next example (below), there is a text string “Test Note” included within the Chart 
Memo Note for the security “NASDAQ.MSFT” (Microsoft on the Nasdaq exchange). For 
this example we searched for some text within the “Note” field. (To view Chart Notes for 
any stock, use the menu option: View > Show Chart Memo (or <Ctrl>+M).
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Icon — set default colour
A number of “icons” are available to apply to a price chart.

See the palette of available icons in the screen shot at right.
These are available from the button on the “Line Studies”
toolbar.

It is now possible to set the default colour for any particular
icon. After applying an icon to a price chart, view the Icon
Properties dialogue, as shown in the screen shot below
(display this by right-clicking on the applied icon, and select
“Icon Properties” from the drop-down menu).

Adjust the properties as desired, then click on the
“Defaults...” button in the bottom left corner of the dialogue
box, and select “Set as my defaults” and click on “OK”.
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Sort Watchlist entries by the Comment field
The watchlists within the Security Manager
include three columns: 
Symbol, Name and Comment. 

It is now possible to sort the watchlist entries
by the text in the Comment column.

To do this, right click on the watchlist, and
select “Sort Order” from the drop-down menu.

Comment field expanded
The Comment field in the watchlists can now accommodate up to 250 characters (in 
version 4.3.1.1).
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